Note: The other languages of the website are Google-translated. Back to English

Dapatkan nilai teks terakhir di kolom

Misalkan Anda memiliki daftar data yang berisi angka, tanggal, teks, kesalahan, dan nilai Boolean (BENAR dan SALAH), untuk mendapatkan nilai teks terakhir dari daftar, rumus berdasarkan INDEKS serta MATCH fungsi dapat membantu Anda.

dapatkan nilai teks terakhir di kolom 1

Bagaimana cara mengambil nilai teks terakhir dalam daftar?

Untuk mengambil kembali nilai teks terakhir dalam daftar seperti yang ditunjukkan di atas, fungsi INDEX dan MATCH akan membantu Anda dengan cara ini: Fungsi MATCH yang diatur untuk melakukan pencocokan tepat menempatkan posisi nilai teks terakhir. INDEX kemudian akan mengambil nilai pada posisi itu.

Sintaks umum

=INDEX(range,MATCH("*",range,-1))

Catatan: Nilai pencarian "*" dapat mencocokkan sejumlah karakter. Itu tidak cocok dengan kesalahan, angka atau nilai Boolean (TURE dan FALSE).

  • Kisaran: Daftar (rentang satu kolom) tempat mengembalikan nilai teks terakhir.

Mendapatkan kembali nilai teks terakhir dalam daftar, silakan salin atau masukkan rumus di bawah ini di sel E4, dan tekan Enter untuk mendapatkan hasil:

=INDEKS(jarak,COCOK("*",jarak,-1))

dapatkan nilai teks terakhir di kolom 2

Penjelasan rumus

=INDEX(B4:B15,MATCH("*",B4:B15,-1))

  • COCOK("*",B4:B15,-1): kecocokan_type -1 memaksa fungsi MATCH untuk mengembalikan posisi nilai teks terakhir dalam rentang B4: B15. Jadi, fungsinya akan kembali 8.
  • INDEKS(B4: B15,COCOK("*",B4:B15,-1)) = INDEKS(B4: B15,8): Fungsi INDEX kemudian mengembalikan 8nilai th dari kisaran B4: B15, Yang Office Tab.

Fungsi terkait

Fungsi Excel INDEX

Fungsi INDEX Excel mengembalikan nilai yang ditampilkan berdasarkan posisi tertentu dari rentang atau larik.

Fungsi Excel MATCH

Fungsi Excel MATCH mencari nilai tertentu dalam rentang sel, dan mengembalikan posisi relatif dari nilai tersebut.


Rumus Terkait

Dapatkan nilai teks pertama di kolom

Untuk mengambil nilai teks pertama dari rentang satu kolom, Anda bisa menggunakan rumus berdasarkan fungsi INDEX dan MATCH serta rumus berdasarkan fungsi VLOOKUP.

Dapatkan nilai non-kosong pertama di kolom atau baris

Untuk mengambil nilai pertama (sel pertama yang tidak kosong, mengabaikan kesalahan) dari rentang satu kolom atau satu baris, Anda bisa menggunakan rumus berdasarkan fungsi INDEX dan MATCH. Namun, jika Anda tidak ingin mengabaikan kesalahan dari rentang Anda, Anda dapat menambahkan fungsi ISBLANK ke rumus di atas.

Ambil informasi yang terkait dengan nilai n terendah

Untuk mengambil data yang sesuai dengan nilai terkecil, terkecil ke-2, atau terkecil ke-n dalam daftar, tabel, atau baris di Excel, Anda bisa menggunakan rumus INDEX dan MATCH bersama dengan fungsi KECIL.

Dapatkan informasi yang sesuai dengan nilai maksimum

Untuk mengambil data yang sesuai dengan nilai maksimum dalam daftar, tabel, atau baris di Excel, Anda bisa menggunakan rumus INDEX dan MATCH bersama dengan fungsi MAX.


Alat Produktivitas Kantor Terbaik

Kutools for Excel - Membantu Anda Menonjol Dari Kerumunan

Apakah Anda ingin menyelesaikan pekerjaan harian Anda dengan cepat dan sempurna? Kutools for Excel menghadirkan 300 fitur canggih yang canggih (Gabungkan buku kerja, jumlahkan berdasarkan warna, pisahkan konten sel, tanggal konversi, dan seterusnya...) dan hemat 80% waktu untuk Anda.

  • Dirancang untuk 1500 skenario kerja, membantu Anda memecahkan 80% masalah Excel.
  • Kurangi ribuan klik keyboard dan mouse setiap hari, hilangkan mata dan tangan Anda yang lelah.
  • Menjadi ahli Excel dalam 3 menit. Tidak perlu lagi mengingat rumus dan kode VBA yang menyakitkan.
  • Uji coba gratis tanpa batas selama 30 hari. Jaminan uang kembali 60 hari. Upgrade dan dukungan gratis selama 2 tahun.
Ribbon of Excel (dengan Kutools for Excel diinstal)

Tab Office - Aktifkan Pembacaan dan Pengeditan dengan Tab di Microsoft Office (termasuk Excel)

  • Satu detik untuk beralih di antara lusinan dokumen terbuka!
  • Kurangi ratusan klik mouse untuk Anda setiap hari, ucapkan selamat tinggal pada tangan mouse.
  • Meningkatkan produktivitas Anda sebesar 50% saat melihat dan mengedit banyak dokumen.
  • Membawa Tab Efisien ke Office (termasuk Excel), Sama Seperti Chrome, Firefox, dan Internet Explorer Baru.
Cuplikan Layar Excel (dengan Office Tab diinstal)
Urutkan komentar berdasarkan
komentar (0)
Belum ada peringkat. Jadilah yang pertama memberi peringkat!
Belum ada komentar yang diposting di sini
Tinggalkan komentar anda
Posting sebagai Tamu
×
Beri peringkat pos ini:
0   Karakter
Lokasi yang Disarankan

Ikuti kami

Hak Cipta © 2009 - www.extendoffice.com. | Seluruh hak cipta. Dipersembahkan oleh ExtendOffice. | Peta Situs
Microsoft dan logo Office adalah merek dagang atau merek dagang terdaftar dari Microsoft Corporation di Amerika Serikat dan / atau negara lain.
Dilindungi oleh Sectigo SSL